Mountain Bike Reviews Forum banner
1 - 20 of 21 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter · #1 ·
Does anyone know if there is a type fault with the '05 frames? The fixing holding the mount on to the seat stay has begun to pull apart on my frame.
I only stated using the frme in April '06.
I know of one other '05 that had the same problem..
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #4 ·
There's not a lot to see in a photo. The mount can only
be seen moving with the brake locked the bike pushed backward.
The problem was noticed because of the really irriating noise made the mount began to vibrate causing seat stay resonated like some filthy monocoq swingarm.
Giant seems willing to deal with it under warrenty so far.
 

·
Gone riding
Joined
·
3,350 Posts
Good to hear. :thumbsup:

Just out of interest, did you ever try and do any trials or street style riding with this XC based frame? The reason I ask is that usually this only happens to mounts when the brakes are used while riding backwards with force. It was a pretty common breakage point on early street frames until manufacturers realised what was happening and strengthened the mount. Just wondering. :D

Best of luck with the new frame!
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #7 · (Edited)
Nah. Not my sort of thing. It was used only for a few XC races (so fairly tame) and a 3 hr spin one even so nothing special and all with forward braking motions.
One suggestion made was heat from the caliper caused the adhesive to melt. I've never check to see how warm they get. All 3 of use were running Shimano brakes - Deore, XT and XTR all with the same effect.
 

·
Gone riding
Joined
·
3,350 Posts
Ok, ok so I missed it! It's not like it was written in big bold font in the subject line for me to read or anything! :rolleyes: :D :p

Yeah, so were there any changes made to the 2006 frames?? I haven't really been following Giants carbon range, I'm still rolling around on a 2002 Aluminium XTC. :thumbsup:

Dave.
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #11 ·
The '05 and '06 look the exact same - the first one ('05) to go was definitely replaced with '06 model. The 2 that arrrived last week could possibly be '07. I'm not sure. Aside from decals, they all look the same.
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #12 ·
The replacement frame "lasted" a week. It was for 1 hout last Tuesday, 2 hrs on Thursday and 1 hr again today. Even before today's ride the mount had started to pull away. I thought I was only imagening it but when I checked, it was as bad the the previous frame.
I wonder what the replacement will be this time?
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #19 · (Edited)
The first of the three replacemet frames has failed too. I can't see the 3rd one last too much longer either as I didn't even get enough time for a good spin out of mine. Tomorrow's savagespin will probably do it.
I should hear back from Giant this week. It will be interesting to hear what they say when a 5th/6th frame has failed.
 
1 - 20 of 21 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top