Mountain Bike Reviews Forum banner
1 - 20 of 30 Posts

·
Registered
Joined
·
1,479 Posts
My money is on it being the ad servers, seeing as with an 8mbit connection it takes me about 1-4 seconds to load this page in firefox, vs 10-20 seconds in IE.

Oh and if I disable ad block, firefox takes 10-20 seconds to load the page. Firefox loads the page as it downloads too, so you can see the forum body load within a few seconds, and then it sits for a while before slowly loading the side advertisement.
 

·
Girt by sea.
Joined
·
463 Posts
Some Guy said:
It's the ad servers, as you suspected. Use FireFox with the Ablock extention to prevent the ads loading. This makes MTBR load much faster.
Where do I find the Adblock extension? (and I assume you meant Adblock, not Ablock ....)

Cheers,
Graeme
 

·
Gone riding
Joined
·
3,348 Posts
I have no issues with the speed of MTBR, regardless of the browser I’m using. Obviously an ad blocker will make a huge difference, but without any extensions I see very little difference in speed between IE and Firefox. Really the only reason I use Firefox is because of the superior interface and its ability to be customized.
 

·
Registered
Joined
·
611 Posts
The only problem i have with firefox is it will not let me watch videos on youtube.I can get the website but it says i have either javascript turned off or an old version of macromedia flash player?It worked fine before i installed firefox any ideas on how to fix this?:madman:
 

·
Registered
Joined
·
1,142 Posts
It's always bugged me how slow MTBR loads even with broadband (windows explorer 7). Just installed firefox yesterday. Holy crap now it loads 10 times faster even without the ad blocker add on.

First time I've even thought about using a different browser. So any tips from Firefox users? What add ons would yoou highly recommend?

Also trying to find the favourites tab at the moment! - - - - Figured it out, Favourites = Bookmarks!
 

·
Registered
Joined
·
611 Posts
bigdamo said:
The only problem i have with firefox is it will not let me watch videos on youtube.I can get the website but it says i have either javascript turned off or an old version of macromedia flash player?It worked fine before i installed firefox any ideas on how to fix this?:madman:
Just fixed it.Installed flash player.
 
1 - 20 of 30 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top