Mountain Bike Reviews Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
359 Posts
Discussion Starter · #1 · (Edited)
Ya know, the K2/Proflex riders tech forum?

I used to go there alot but not in a long while, now it seems to be gone :???:
 

·
Registered
Joined
·
359 Posts
Discussion Starter · #3 ·
go-pirates said:
I just tried it (www.idriders.com) and it worked fine. Remember to scroll down to get to the K2 / Proflex forum.
I've tried everything, including your link and I can't get there. Must be a problem on my end the page wont load and I waited a long time :madman:
 

·
Registered
Joined
·
731 Posts
Hmmm. I'm using Safari instead of Explorer. That might explain it. There's a site for 29 ' bikes which is the oppoite; I can only get it using Explorer, and not Safari.
 

·
Registered
Joined
·
4,013 Posts
HJB said:
Ya know, the K2/Proflex riders tech forum?

I used to go there alot but not in a long while, now it seems to be gone :???:
Here's a direct link to the current message board for ya'.

http://idriders.com/cgi-bin/YaBB_K2/YaBB.pl?board=news

The other link is from the old days. Things have changed a bit since then. If you're having a problem with loading pages get yourself a free version of someone's tracking cookie cleaner (Lavasoft's AdAware is great!) and clean up your PC. Everything is fine there (okay, except the number of non-registered crap posts from ad-bots and the like's).
 

·
Registered
Joined
·
359 Posts
Discussion Starter · #6 ·
I made it

Hoooray for me :drumroll: After deleting my history and cookies and cleaning out the temp files I can get there again :thumbsup: . Basically some much needed house keeping ;) Not bad for a computer illiterate dummy :crazy:
 
1 - 6 of 6 Posts
Top