Mountain Bike Reviews Forum banner
1 - 17 of 17 Posts

·
Registered
Joined
·
645 Posts
Discussion Starter · #1 ·
since most people using the ti eggbeaters are WW anyone having issues using the ti versions? Looking at switching from the st to the 2 ti since there is no weight limit and I am over the 185 weight limit for the 4 ti.
 

·
ups and downs
Joined
·
15,599 Posts
I have 3 pairs of the 2Ti on three bikes, I'm about 195 pounds and I've never had an issue with them. They need the same regular greasing as the SL's but as long as you do that they are golden (well matte black actually).
 

·
Go faster!
Joined
·
1,144 Posts
Does the ti version get a massive play on the wings? My second set of eggbeaters SL are getting worse with time..
I thought about getting the 4Ti but if they all have the same problem, no way then.
 

·
Registered
Joined
·
183 Posts
sergio_pt said:
Does the ti version get a massive play on the wings? My second set of eggbeaters SL are getting worse with time..
I thought about getting the 4Ti but if they all have the same problem, no way then.
Yes my Ti are getting a fair amount of play after around 3,000 km. However I have greased them precisley never and they still hold my cleats firmly so I not complain.
 

·
Go faster!
Joined
·
1,144 Posts
grease wont solve the issue has I lube mines when they get dry or dirty.
Its about time crankbrothers solve this wear problem.
 

·
Registered
Joined
·
964 Posts
sergio_pt said:
grease wont solve the issue has I lube mines when they get dry or dirty.
Its about time crankbrothers solve this wear problem.
I've had good luck with CB, if you tell them what's going on - they rebuilt mine and play was gone. (at least for a while) just cost me shipping one way.
 

·
Registered
Joined
·
2,937 Posts
I broke one of my 2Ti. pedals. The beater came right off the axle. I clipped out and the beater was still attached to the bottom of my shoe! It's my own fault, I never did any kind of maintenance on them in probably four years. I'll try sending them back to CB and see what they say.
I have the 4Ti.on my other bike. I don't ride that one as often but I've had no problems so far. I would buy another set of Eggbeaters. The only other pedal I would consider would be the new XTRs.
 

·
Go faster!
Joined
·
1,144 Posts
slcpunk said:
I've had good luck with CB, if you tell them what's going on - they rebuilt mine and play was gone. (at least for a while) just cost me shipping one way.
Cool, I might have to bug them about this. I like my pedals fine tuned :)
 

·
Registered
Joined
·
564 Posts
I've used at least six different CB pedals over the past 3-4 years, only problems were with the Smarty, and that I believe is because its the "cheap" version.
 

·
Go faster!
Joined
·
1,144 Posts
dewthedru said:
i have the 2ti and weigh 185 or so. never do any sort of maintenance and they've been problem free for 2+ years.
They dont have any kind of play for two years? How often do you ride?
 

·
Registered
Joined
·
356 Posts
not a ton. probably 800 miles on the mtb this year. i do tighten the screw at the end once in a while. i've gotten new cleats as well i guess.
 

·
GONE
Joined
·
26,255 Posts
shortpull said:
anyone have a problem with the springs in their eggbeaters breaking? (sl, ti, 2ti, 4ti all use the same steel spring i believe.)
No problems at all! I've been riding my Ti's for a year now and other than an ocassional loose end cap, They still perform like new!
 

·
Waiting for Godot
Joined
·
1,054 Posts
i've had mine on most of the year and have only recently somehow cracked one of the clip in bars. i put in alot of miles and ride most days.

they still work though.
 
1 - 17 of 17 Posts
Top