Mountain Bike Reviews Forum banner
1 - 7 of 7 Posts

·
UNDEAD
Joined
·
485 Posts
Discussion Starter · #1 ·
Help!

I've got this creak that is driving my nuts!
I can't seem to locate the exact spot but it's coming from the center of the frame around the shock area/pivots
It's a slight creak, only audable under slight vibrations
Tonight I am taking the whole shock (DHX 4.0) off, cleaning and greasing what I can, hopefully this will work.

Anyone experianced anything like this, what was it exactly?:confused:

Thanks!
 

·
Registered
Joined
·
895 Posts
Could be several things

My annoying creak was the result of a misaligned bearing in my main pivot. Pressed it in = no more noise!

The stock Specialized seatpost seems to creak a lot on these bikes - check this first.

Next I would clean and check all your pivots and torque them to spec (Spec has the values on their site)

Edit:
Of course, as always, have a look at you bb, and chainring bolts - can cause the creaking noise you are experiencing
 

·
Registered
Joined
·
215 Posts
I had this same thing happen a couple of weeks ago on a brand new Stumpjumper. I thought it was the shock as well, but it turned out to be the seat post.

Before you rip your shock out and start taking things apart, apply a small amount of grease to your seat post.

Money says she'll stop creaking. Also, make sure the seat post clamp is tight....
 

·
I dig trails!
Joined
·
5,611 Posts
bxb03a said:
I had this same thing happen a couple of weeks ago on a brand new Stumpjumper. I thought it was the shock as well, but it turned out to be the seat post.

Before you rip your shock out and start taking things apart, apply a small amount of grease to your seat post.

Money says she'll stop creaking. Also, make sure the seat post clamp is tight....
Seat post for me too!

Mr. P
 

·
UNDEAD
Joined
·
485 Posts
Discussion Starter · #6 ·
K

I'm doin both...

Shock cleaning (could not hurt/shuttle/mounts)
and seatpost cleaning re-lube

Got my fresh tube of Phil's grease all ready to go when I get home

Thanks for the help!
 

·
Registered
Joined
·
1 Posts
Bearing Nut

Hey, I had the same problem with my SX, and it turned out to be the nuts on the bearings. There is supposed to be a small lip on the inside so that when the bearing rotates it doesn't rub against the nut itself. However on mine (08 SX I) there was no such lip. My lbs got in touch with specialized about it and they sent some different nuts that sure enough had this supposed lip on them. Another way to fix it, and what my lbs did for me while I waited for the new nuts to arrive was place a small washer infront of the nut, and that worked fine, no more creak. It also fixed an issue where I kept on having to re-tighten those nuts cause they were being worked loose from the action of the suspension. Hope this helps!
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top