Mountain Bike Reviews Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
215 Posts
Discussion Starter · #1 ·
My friend and I installed my rear Avid BB7s last night. The fronts went on last week and are working beautifully. My rear caliper, however, wont always completly retract despite having the spring tension adjuster as tight as it will go. This is even WITHOUT the cable attached so I know that it is not a cable routing/binding issue. I dropped my bike off at the shop where I purchased the brake this morning and they will look at it today and they say that they will replace the caliper if it is defective.

Has anyone else had this problem with Avid BB7s? Is it a matter of the caliper just getting "broken in" a bit? My front caliper does not have this problem so I'm not completely willing to accept that as an answer from the shop where I got the brake. They haven't claimed that this is the problem yet but I'm just trying to anticipate some of their possible responses to my situation.
 

·
Premium Member
Joined
·
48,238 Posts
Pull the caliper off the bike and check it. If it is still binding, pull the pads and check again. If it is binding off the bike and without the pads I would say it is defective.
 

·
Registered
Joined
·
215 Posts
Discussion Starter · #4 ·
According to the mechanic at my LBS, the spring was a little offset from the factory so it wasn't functioning properly. Problem solved.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top