Mountain Bike Reviews Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,191 Posts
Discussion Starter #1 (Edited)
I have a stock Moonlander and switch between BFL's for summer and Bud/Lou in winter. I've done this for 4 years with both split tube and gorilla tape with no issues.

Today I was putting on Bud and Lou using Qtubes and had a hard time getting air through the valve stem (core removed). It was like the air chuck (using compressor) wasn't compatible with the stem. I wasn't getting good air flow and at one point the little "pin" inside the air chuck was hanging up. It was also hard to pull the chuck off the stem. I couldn't make it work and eventually had to use my blow gun attachment to get the tire to take enough air to seat. It's much more difficult this way since the blow gun attachment doesn't fit inside the stem and I have to hold perfectly still to keep the air going in.

Do the Qtubes have an odd size stem?

Is there something wrong with my air chuck?

These are the Qtubes I'm using.

ImageUploadedByTapatalk1453066347.410685.jpg


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
123 Posts
I assume you are using a presta valve chuck so, maybe the chuck is bad. When I was an auto mechanic I replaced mine a few times a year. Moisture from the compressor can cause the rubber inside the chuck to rot and no longer work properly.
 

·
Registered
Joined
·
1,191 Posts
Discussion Starter #3
I assume you are using a presta valve chuck so, maybe the chuck is bad. When I was an auto mechanic I replaced mine a few times a year. Moisture from the compressor can cause the rubber inside the chuck to rot and no longer work properly.
Interesting as I replaced my chuck since my last tire swap.

I use an "adapter" to air up my tires which I assume is schrader?

I guess the obvious question is what is the valve stem on the Qtubes...Schrader or Presta?


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
123 Posts
Well the box says presta right on it so unless it was mis-boxed that is what it should be. From the adapters (schrader to presta) I have seen, they only work with the valve in place.
 

·
Registered
Joined
·
1,191 Posts
Discussion Starter #5
It was an extra chuck that was sitting around for a while so it could be bad.

Any recommendations on a decent chuck? Not Harbor Freight...;).


Sent from my iPhone using Tapatalk
 
1 - 5 of 5 Posts
Top