Mountain Bike Reviews Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
306 Posts
Discussion Starter · #1 ·
I have an RP3 on my Cannondale Rush. When I let some air out there is a greenish mist that sprays out. It feels like a lubricant. I can't imagine this is supposed to happen. What kind of problem do I have?
 

·
Registered
Joined
·
203 Posts
I sent my RP3 to PUSH to get tuned and when I got it back I had a similar sounding blue fluid escape from my schrader valvle when I let air out. I called PUSH and they told me it was assembly fluid and nothing to worry about.

The shock works fine so far, so in my case it was nothing to worry about.

This might be the case with your shock, it sounds similar.
 

·
Registered
Joined
·
17 Posts
that happened to my TALAS also but its ok. its the fox fluid that they put on the oil seals and it happens to almost all fox shocks i think. yup fox said there's nothing to worry about as long as its not the clear oil you're losing.
 

·
Super Moderator
Joined
·
20,810 Posts
as the others said..it is just the normal chamber lube...nothing to worry about...

actually if it stops doing that completely.. you should check as it might be time to open it up and lube it again
 

·
Registered
Joined
·
934 Posts
Another vote for "perfectly normal". Same thing happened, and still does, to me with my Fox Float with Brain on my Epic. Emailed Fox and they told me it's just lube. As crisillo mentioned, I think we should worry when we don't see any lube at all.
 

·
Registered
Joined
·
289 Posts
I just rebuilt my fork and to my surprise the FOX shock oil (7wt) that I bought is actually green in color; like bright green. Almost like antifreeze! I thought it was pretty cool since the stuff I poured out of the fork was black...
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top