Mountain Bike Reviews Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
314 Posts
Discussion Starter · #1 ·
wondering if anyone else runs into this-

I just got this rack, its been great. But yesterday when I went to release the front wheel hook/clamp thing, that blue release button just pressed in easy. The hook was ratcheted down tight, but the blue button had no resistance inside it like normal, I could just press it and nothing happened. I ended up deflating the front tire so I could get the wheel out. After this I was able to ratchet it down a little more and trigger the mechanism to click and release... if that makes sense.

So now im nervous of getting it stuck on there, its happened again but im careful to notice and have been able to force it down another 'click' and the button was tight again.

Is this just a normal quirk, maybe lubricating the ratchet rail part could help?
 

·
Registered
Joined
·
134 Posts
I usually push the hook down an extra click, especially when it's an inch or so in front of the bike's fender. I usually have to push or squeeze pretty hard on the button to get it to release.

So, are you sure you pushed it far/hard enough?

I don't know about lubricating the ratchet, but occasionally I've been having some binding along the slide at maximum hook extension, but I'm not going to lube it. I figure it'll just attract too much dirt, and the dirt would make it worse. A little hit on the hook loosens it enough so it starts sliding easily enough.
 

·
Registered
Joined
·
5 Posts
I've noticed mine doing that with larger knobbier tires. After it clicks when down, I just push up to check it (without pushing the blue button). It will click in to a natural spot, then the blue button has the proper tension. I think there is just a little bit of tolerance there.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top