Mountain Bike Reviews Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
586 Posts
Discussion Starter · #1 ·
I have bleeded my 2016 Reverb several times but still it after 10 rides in that i does not want to come up and is totally stuck.

What to do? is it a warranty or something I can fix. Any suggestions?
 

·
Registered
Joined
·
1,824 Posts
Time for a full rebuild! Enjoy that!

Find someone with experience. Call around. In our area, you can find 99% of shops have never done it and one that does it all the time.

mk
 

·
Registered
Joined
·
9,754 Posts
Something to check is if the seat post clamp is too tight. You also need to ensure the remote is working properly and actuating the post. Bleed well with speed control full slow, then see how the post responds as you turn the speed control faster. If those things are good, then it's on to service the post itself.
 

·
Registered
Joined
·
2,174 Posts
Make sure you've got the proper psi, hopefully it just needs air.
 

·
Registered
Joined
·
721 Posts

·
Registered
Joined
·
586 Posts
Discussion Starter · #10 ·
The pressure was 150 psi. Put air in it to 250 psi but it was still extremely slow. Bled it and only a little air in the system but now it is extremely fast. I wonder how long this will last. I am really puzzled about the reverb.
 

·
Registered
Joined
·
2,174 Posts
You should be able to adjust the speed by the lever. Does sound like a combination of problems. Hope it stays working well.

That being said I've been quite impressed with my pnw bachelor if you're internally routed.

Old one is being sold at backcountry for $200 (30.9 only), 10% back from active junky as well.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top