Mountain Bike Reviews Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
24,083 Posts
Discussion Starter · #1 ·
I figure I know what's wrong, but thought I'd post up for some thoughts. Have a riding buds bike here and when I got it he was complaining of blowing through the travel on his last ride, even with it set @ 150 PSI - he weighs about 190-200. When he brought it to me it wouldn't go more than about 1: into the travel then was hard like a rock - MC damper engaged or not.

So I take it apart starting with the MC unit and when I remove the MC damper the oil level seems very low, so I drop the lowers and out comes the rest of the camper oil from the bottom of the right leg. I proceed to take everythign aprt, lube all o-rings and out it back together, check the oil levels carefully in the MC unit and at first everything is OK, but then after a short ride around the yard it's back to not getting travel, oils managed to get into the lowers again causing it to not be able to go any further.

My thought is that no matter the seals looked fine and I lubed them somehow they aren't working properly OR something is up with the MC rebound unit and that's letting oil through but not back up :| any thoughts would be appreciated. Going to try swapping the who unit from my 26" spare REBA into his 29er and see if this solves anything :skep:
 

·
Registered
Joined
·
24,083 Posts
Discussion Starter · #4 ·
Criss, thanks, will look more carefully when I open it back up tonight. I suffered a break of sorts on the MC damper that the position to engage it was reversed. Anyways we'll see what I find tonight.
crisillo said:
did you check the circlip that holds the rebound piston?

once one broke on my Pike and the oil ended up in the lowers
That would be a plan since the fork is only a couple months old, EXCEPT, for the fact that with regards to this sort of stuff I am probably the most knowledgeable person on my island and 2nd I'm on an island in the Caribbean with 2 shops which cater to roadies with some lower end MTBs and have no clue about MTbs in general.

ScottW said:
You might have whatever shop you use warranty it. I had the same issue with my Lyrik (I'm guessing it was from a bad o-ring) and Rock Shox just sent me a new fork.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top