Mountain Bike Reviews Forum banner
1 - 4 of 4 Posts

·
Mr. Knowitall
Joined
·
869 Posts
Discussion Starter · #1 ·
Hi
I do not like noises on my 575, and I have noticed a rattling noise from something. I think I have isolated it to the head tub badge being somewhat loose. Have anyone experienced the same and maybe would share a solution for me? I guess some kind of glue/silicone should do the trick, but it must look good as well.

Thanks in advance :)
 

·
Registered
Joined
·
316 Posts
I hit the headbadge on my 303R a few time with a dead blow hammer. Not a hard hit but some taps to seat the rivet back it. I did that a few times and I haven't had any more problems.

A shim in the back would work for awhile but it will just come out slowly again. The rivets don't penetrate enough to keep it tight unfortunately.
 

·
Mr. Knowitall
Joined
·
869 Posts
Discussion Starter · #3 ·
Thanks. I will get myself a dead blow hammer and try later on. Hope this is the cure I am looking for, or else I will have to look for other sources of rattling. And no - there are no rattle snakes in Norway :)
 

·
Pin it to win it
Joined
·
486 Posts
It could definitely be that. I knocked the headbadge loose on my 575 in a crash earlier this year and a few weeks later it started making a rattling noise. Not sure how it was fixed... I had to have some work done at the shop the next day so I asked them to take a look at what was making the noise and they identified the headbadge as the culprit and fixed it. Not sure what they did but it looks as good as ever and doesn't rattle anymore.
 
1 - 4 of 4 Posts
Top