Mountain Bike Reviews Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Problems with Juicy 5's
Hey guys,

Am new to the forum so go easy on me hehe, nice to be on here though

My Juicy 5's weren't exactly performing really well but then again, my last service was a year ago, i first changed my pads but then worn them out again, thereafter my brakes were not responding properly anymore, so i decided to research and found out about bleeding, set ups and so on!

SO so far i managed to Bleed the brakes, replaced the pads AGAIN and well from today the bike brakes really well...however!! the brake handles i have to like pull them 5cm ish for it to fully take on full charge, when i bought the bike a slight touch about 2cm and the brakes were applied fully!

Is there something that can be done about this, or did i do something wrong while bleeding the brakes.

any help is welcome
 

·
Registered
Joined
·
92 Posts
My brother is having a very similiar problem as well. He just got a set of Juicy 5's installed on his bike. The rear brake feels fine, it engages just as it should when pull the levers 2cm or so. But his front brake does not feel like its engaging at all, and you have to pull it almost all the way to the handlebars to get to pads to actually engage the rotor. It feels impossible to get any braking power with the front brake right now.

I have a set of Juicy 5's on my Enduro and both of them engage very fast pulling on the levers about 2 or so cm's. So i'm not exactly sure what the issue is with his front brake, maybe an incorrect installation, or maybe air in the line? Maybe some others can shed some light on this?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
the pads are fine, there set just right....like their most probably in perfect position!

just the elvers not set right in my opinion, something wrong there i guess
 
G

·
You need to add more fluid, some people slightly over fill the juicy 5 in order to get less lever free play.
 

·
Registered
Joined
·
555 Posts
You may need to rebleed. Or you can try to remove the rotor from between the pads, squeeze the lever to pump out the pistons a bit, and then top off the MC with DOT fluid.
I could be wrong, but I thought you werent suppost to pull the lever without the caliper in between, causing the pads to lock up? If Im wrong, please correct, cause I just set up my first pair of hydros at the lbs today lol
 
G

·
Mountain biker 41 said:
I could be wrong, but I thought you werent suppost to pull the lever without the caliper in between, causing the pads to lock up? If Im wrong, please correct, cause I just set up my first pair of hydros at the lbs today lol
That is correct. The way to do it or at least the way I do it is to put something "thiner" than the rotor between the pads, I use a very thin butter knife. Then when you pull the lever the pads close together but you can stiill pull them apart with the knife. Now with the lever pulled in the fluid level will drop and you can now top it up. Once you get to putting the wheel back in it will be a squeeze as the pads will be closer to the rotor but you will have less lever play. Hope that helps.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top