Mountain Bike Reviews Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
I am wondering why my newly purchased ENO chainring is not quite tight on the new crank arm. I've tightened the lockring and it doesn't seem to make good contact with the chainring as I can move it slightly. Can anyone tell me what may be the problem?

This is what I'm feeling right now: :madman: I figured I run it by you guys before I checked with White Industries in the a.m.

Thanks in advance!
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #3 ·
I tried that and it didn't work. Thanks for the suggestion though. It looks like the lockring bottoms out before bearing on the chainring, thus, it won't tighten fully. I guess I'll email White Industries today.
 
Joined
·
11 Posts
fireattackvdf335 said:
I tried that and it didn't work. Thanks for the suggestion though. It looks like the lockring bottoms out before bearing on the chainring, thus, it won't tighten fully. I guess I'll email White Industries today.
I received a set of White Industries cranks yesterday and installed the chainwheel/ring with the lockring backward first (fingertight) and noticed it didn't bottom on the ring. After flipping it there was no problem. Hence the suggestion. I'm sure White will help you out though.
 

·
Registered
Joined
·
1,171 Posts
I bet

fireattackvdf335 said:
I tried that and it didn't work. Thanks for the suggestion though. It looks like the lockring bottoms out before bearing on the chainring, thus, it won't tighten fully. I guess I'll email White Industries today.
you have the ring flipped.

When I bought mine I accidentally flipped the ring as discussed...when I tightened it I bunged the threads slightly...when I then tried to install it correctly, it seemed as if that was not working either, I stayed the course and tightened it (knowing that the threads were slightly jacked and that was why I had the small amount of resistance).

Now, the ring does not bottom out, chainwheel is solid! May be that is what you have going on?
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #7 ·
Well, I want to thank everyone for their replys and assistance. Problem solved. It seems when I had the idea to flip the lockring, I took it off and installed back in the same position. I know, I know, I'm a dumbas$. By the way, WI got back to me in a timely manner too and that was appreciated. Thanks again!!!

Happy trails!
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top