Mountain Bike Reviews Forum banner
1 - 6 of 6 Posts

·
N* Bomber Crew
Joined
·
4,271 Posts
Discussion Starter · #1 ·
I got this really odd problem...

Something in my rear frame/wheel assembly on my bike feels loose or has play. I checked all my bolts and fastened them down, but I still won't go away.

I feel the play most noticeably when I hike my bike up a hill, and my rear wheel rolls over a rut or something, it makes a clank, and it feels like the shock mounting is loose...but its not.

Does anyone have any obvious places to start checking/looking? My frame is a 04/05 Weyless 67.
 

·
Glad to Be Alive
Joined
·
43,010 Posts
I would go through and take apart all my pivots of the rear end and regrease and re-tighten them........same thing on the wheel...re-pack bearings on that.......go through the shock mounts too....pedals and BB and (might as well do it all)...while you are at it but not the problem the headset too.

quick fis rear wheel, shock linkage and frame pivot

Good luck
 

·
N* Bomber Crew
Joined
·
4,271 Posts
Discussion Starter · #3 ·
SHIVER ME TIMBERS said:
I would go through and take apart all my pivots of the rear end and regrease and re-tighten them........same thing on the wheel...re-pack bearings on that.......go through the shock mounts too....pedals and BB and (might as well do it all)...while you are at it but not the problem the headset too.

quick fis rear wheel, shock linkage and frame pivot

Good luck
I'm curious...do shock bushings ever "wear out"?
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top