Mountain Bike Reviews Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
704 Posts
Discussion Starter · #1 ·
Hey guys, I got a brand new Lefty SL, I have used it not more than 10 rides, yesterday i checked the pressute on the lefty, it was Ok, i dropped to 0psi them back to 110psi. when for a ride and the lefty feel really soft, when I looked at the Boot, it was half way compressed. came back to the car check the pressure was in 50psi. i added more psi but within the first 3 miles in the trails it goes down to 50psi.. What could be the problem.... I also have another SL in my carbon Rush, with not a single problem....
 

·
mad aussie
Joined
·
1,129 Posts
Most likely problem would be a bad schrader valve core, you do need a specific one for the Lefty. I have run across issues with them on all kinds of air shocks and forks. Remove the core from the valve at the bottom and replace. After that I would check the lower plug that contains the valve has good o-rings and is greased properly and if that fails replace the piston.
I had a slow leak, replaced the valve core (took 1 minute) and now life is good.

Kevin
 

·
mnt bike laws of physics
Joined
·
2,761 Posts
My SL which I got a few weeks ago came with a valve core that did not respond to the shock pump. This exact same thing occured with the SPV chamber of the Lefty Max I got in 2006. I replaced both cores with ones from rear shocks and now no problems. I even use the manitou shock with which I put the valve core of the SL, and it responds perfectly to the pump gauge. :confused:
 
1 - 3 of 3 Posts
Top