Mountain Bike Reviews Forum banner
1 - 12 of 12 Posts

·
Professional Nerd
Joined
·
298 Posts
Discussion Starter · #1 ·
My 2004 VT2 frame arrived in the mail on Monday. Last night I popped "The Collective" in the DVD player, grabbed a few bottles of Honey Brown and proceeded to build the bike up. A great evening indeed.

Everything went well, but I do have one question for all of the VT owners out there. Since it was a "frame only" kind of deal, I didn't have any kind of cable stop for the rear derailleur cable on the rear triangle. I am running housing all of the way from the top tube to the derailleur. I was wondering if anyone knew where I could pick up the insert (assuming there is one...) and if anyone could possibly show me an up close picture of their set up. The first of my pictures below should describe what I am talking about.

Pic 1: Cable boss. It shifts surprisingly well for having a 2' section of housing...
Pic 2: Fresh out of the box. The satin black finish is incredible...
Pic 3: No seriously, the satin black finish is incredible.
Pic 4: A few beers, a sexy frame and some Bike Lust. Should have busted out some candles and dimmed the lights.

Fully built pictures to come soon.

Thanks!
-Danimal
 

Attachments

·
Professional Nerd
Joined
·
298 Posts
Discussion Starter · #3 ·
Yeah, that may very well be true. The only picture I'm going off of shows a cable stop. Granted...it is from Giant and could have been taken before production, when the bike was still a "prototype". The linkage in this picture is black...which makes me think this is the case.

Sorry for the large image size.



-Danimal
 

·
Registered
Joined
·
50 Posts
Another VT from Scratch

I see you're running the cable w/housing in that middle section. Mine is like the one on the large picture with the open cable showing. The housing does need the bigger stoppers and when I did mine the Local Bike shop had them so I don't think you should have a problem finding them at all. I built mine from the frame up as well, nothing is like the original and I love it. The Satin finish is sweet on yours! I'll give mine a clean this weekend and post a full pic of it here later. Good luck!
 

Attachments

·
Professional Nerd
Joined
·
298 Posts
Discussion Starter · #5 ·
Hey, thanks for the reply!

Yeah I figured there would be a cable stop, but I am curious as to why Giant did not put a standard cable boss on the frame to eliminate the need for the insert.

I'm all excited to see your bike built up too! I noticed you have the black linkage for the rear suspension...I've never seen one like that before (except for the picture from Giant) and assumed that all of them had them in silver (like mine).

I will go to the LBS and ask around for the cable stops, thanks for the tip!

How long have you been riding your VT2? I got mine out for an hour at a local trail and it was amazing. The bike fit perfect, and it handles single track just as well as it handles my light free riding. I took a 5' drop on it (4' bigger than the biggest I've ever gone...) and it was unreal.

Unfortunately, I am not super happy with the paint. After 1 hour of riding, my cables have warn the paint very badly and they really aren't even rubbing very hard on the frame. I will be picking up some frame patches tomorrow before I ride. After light use, my 2003 Giant Iguana looks pretty warn as well. With all of the bragging Giant does on the "Diamond" clear coat system, I am super dissapointed.

Lets see some pictures of your VT!!! I am totaly in love with my VT and am looking forward to the next few years of riding it.

Thanks,
-Danimal
 

·
Registered
Joined
·
50 Posts
Sure thing...

I'm actually installing the new Avid BB7 8" Disc up front tomorrow since I just upgraded from a Psylo for to the Manitou... come to find out the Minute Fork Post Mount is different so my XT 160mm Hyd. brake won't work unless I invest into a new 170mm rotor and adapter from Shimano which I figured, might as well go bigger since Manitou already told me I can run an 8" rotor up front. I'll go ahead and post the photo once It's all put together again. I've had mine for about a year now and bought the VT1 frame from a LBS and it was new, the prior owner took all the components and put em' on a Turner... @#&*!? Anyways, I love the way these VTs handle and climb, I've been wanting to weigh mine cause it feels lighter than my other 3 buddies' VTs. Most of all the components are less than 6 months old so it's feeling better each time. I'm sure you'll be enjoying your for a long time to come.
 

·
Registered
Joined
·
50 Posts
Here's mine now...

Ok, got the Minute Fork and the 8" Discs installed so here's the pic of the finished bike. Feels amazing and I'm looking forward to the weekend ride, enjoy! You can check my profile for the full specs, all custom.
 

Attachments

·
Freshly Fujified
Joined
·
8,199 Posts
Nice bike Dan

Danimal said:
Unfortunately, I am not super happy with the paint. After 1 hour of riding, my cables have warn the paint very badly and they really aren't even rubbing very hard on the frame. I will be picking up some frame patches tomorrow before I ride. After light use, my 2003 Giant Iguana looks pretty warn as well. With all of the bragging Giant does on the "Diamond" clear coat system, I am super dissapointed.
I had a similar experience with my '04 Warp which was stealth black. It looks great off the showroom floor, but has absolutely no durability. For all that Giant does right, I've heard a lot of complaints about the durability of their paint jobs.

Enjoy the bike.

Clyde
 

·
"El Whatever"
Joined
·
18,889 Posts
Call_me_Clyde said:
I had a similar experience with my '04 Warp which was stealth black. It looks great off the showroom floor, but has absolutely no durability. For all that Giant does right, I've heard a lot of complaints about the durability of their paint jobs.

Enjoy the bike.

Clyde
I have had two Warps... the current is a '04 DS2 in team blue. The previous was a '03 DS1 in white.

The '03 had a (by far) better paint job than the '03. I think Giant quit the "Diamond Coat" on '03.... The '04 as Clyde said is a mess. Cable rub everywhere and dust just play havoc with it. The '03 was impervious to mud and dust.

Just my quote of confusion....
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top