Mountain Bike Reviews Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
76 Posts
Discussion Starter · #1 · (Edited)
Hello. I just got an 08 Mojo frame. The headset I am trying to put in is an FSA Orbit IS. I'm having a little trouble with the installation. I've got the race on and bottom bearing. When I put the top bearing on the fork, it wants to slide all the way down the headtube (even with the compression ring on) until it touches the bottom one. I was finally able to get it to stay up top, but I don't know how reliable it is going to be when I'm riding. It seems like there should be a lip or something that prevents it from sliding all the way down. Supposedly, this headset was used in this frame before, so I don't think I've got the wrong size. Am I just missing something? Or do I maybe have the wrong size headset? Thanks.
Sam
 

·
Registered
Joined
·
2,440 Posts
RotarySam said:
Hello. I just got an 08 Mojo frame. The headset I am trying to put in is an FSA Orbit IS. I'm having a little trouble with the installation. I've got the race on and bottom bearing. When I put the top bearing on the fork, it wants to slide all the way down the headtube (even with the compression ring on) until it touches the bottom one. I was finally able to get it to stay up top, but I don't know how reliable it is going to be when I'm riding. It seems like there should be a lip or something that prevents it from sliding all the way down. Supposedly, this headset was used in this frame before, so I don't think I've got the wrong size. Am I just missing something? Or do I maybe have the wrong size headset? Thanks.
Sam
huh? i think i am missing something :D

mx
 

·
Registered
Joined
·
76 Posts
Discussion Starter · #6 ·
Ok. I figured it out. The frame was shipped with some plastic plugs covering the top and bottom of the headtube. I just looked at the plugs, and one of them had pulled the metal sleeve out with it that goes on the top of the headtube. That metal sleeve holds the top part of the headset up. That is why it was just sliding down to the bottom. So, I WAS missing something.. haha. All is good now. Thanks for your time.
 

·
Registered
Joined
·
2,440 Posts
RotarySam said:
Ok. I figured it out. The frame was shipped with some plastic plugs covering the top and bottom of the headtube. I just looked at the plugs, and one of them had pulled the metal sleeve out with it that goes on the top of the headtube. That metal sleeve holds the top part of the headset up. That is why it was just sliding down to the bottom. So, I WAS missing something.. haha. All is good now. Thanks for your time.
have fun assembling your new bike!

mx
 

·
Registered
Joined
·
236 Posts
HOLD UP COWBOY!!!
It is a Mojo Classic or SL you're building up...
It sounds like a Classic, cos the SL has carbon races. That "metal lug" sounds like the upper bearing race. It's meant to be bonded to the headtube.
You'd better give Ibis a call and have a chat to them..
 

·
Registered
Joined
·
76 Posts
Discussion Starter · #9 ·
littlejohn said:
HOLD UP COWBOY!!!
It is a Mojo Classic or SL you're building up...
It sounds like a Classic, cos the SL has carbon races. That "metal lug" sounds like the upper bearing race. It's meant to be bonded to the headtube.
You'd better give Ibis a call and have a chat to them..
It's a regular Mojo. Yeah, I know it's supposed to be bonded to the headtube. I took care of it. I'm not worried.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top