Mountain Bike Reviews Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
242 Posts
Discussion Starter · #1 ·
I hade a ride this wednesday and the brakes worked perfectly. The adjustment screw on the lever has been fastened and is no longer a problem.

Today, friday, I was ready to go riding and took the bike out just do discover that I no longer had a rear brake. It goes all the way to the handlebar and is just starting to grab when it's touching the handlebar. I then thought it might be a leak that had been leaking since my last ride or something like that (no prior problems with these brakes beside the adjustment screw backing out). I went over the brake visually but didn't find any signs of leak anywhere. Neither did I find any residue of oil or anything on my floor where the bike had been standing since my last ride.

So, if there is still just as much liquid in the system and the adjustment screw in place how can the lever touch the handlebar ? Is there something I'm missing or is it probably a leak that I just havent found yet? I know that the brakes worked perfectly all the way to my doorstep my last ride since it's a hill right outside my door.

I've been searching the forum but didn't find anything that sounded like an explanation to my problem.

Should I get the bleedkit and bleed the system or wouldn't that be any good since I probably have a leak or another problem that won't be solved by a bleed ? The bike was washed with a water hose with very little after my last ride. Could water in any way affect the brake like this ?

Appreciate any help :)
 

·
Registered
Joined
·
138 Posts
definitely rebleed

probably air bubbles, just happened to me after what i thought was a good bleed. it took a couple days before i got the squishy lever. re-bled and perfect
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top