Mountain Bike Reviews Forum banner
1 - 7 of 7 Posts

·
Dad
Joined
·
187 Posts
Discussion Starter · #1 ·
I just tried to use my Turner/Dualco grease gun for the first time yesterday, and after the first two pivots it stopped working. I tried a few minor things to get it going again, but failed.

Any suggestions? This was the first time I used it, so I have trouble imagining it's broken already.
 

·
Just another FOC'er
Joined
·
2,222 Posts
It's probably not primed.

I find I've got to squeeze all the air out of the grease tube before screwing it on and then leave it sitting with the tube up when not in use to keep it primed.
 

·
No, that's not phonetic
Joined
·
14,313 Posts
Yup, like danno said, vapor-lock. I put a big spring binder clip on my tube to keep pressure on it so that it will force bubbles through the pump head.
 

·
Natl. Champ DH Poser/Hack
Joined
·
12,942 Posts
also ive heard it said a quick dip in some hot water frees things up. i too suffered from the dreaded dualco diss but dannos trick worked wonders. im diggin cheeses clip idea at the moment and will try that. any need to reprime after the clip was added?
 

·
Registered
Joined
·
187 Posts
Very useful thread! I was having the same problem and was about to call Turner to complain about the lousy grease gun they sold me. Makes sense that it just needs to be primed. Once again the Turner Forum comes through. Fortunately, my trusty Burner hasn't been squeaking, despite my inability to lube the pivots.
 

·
Registered
Joined
·
134 Posts
a better solution is to buy a the gun with the metal canister. It has a spring loaded bottom that keeps the air out. Just replace the tip with the turner one. You don't get the broken thread on the tube mess either
 

·
Natl. Champ DH Poser/Hack
Joined
·
12,942 Posts
all true brian. by the way, congrats on yer reincarnation as a bike geek. i loved yer work in the stones.
 
1 - 7 of 7 Posts
Top