Mountain Bike Reviews Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter · #1 ·
I've had my Juicy 7's for a little over a year now. They supposedly came pre bled and worked great for the first couple of months. Then the rear brake, became would quit working and allow me to bring the lever all the way to the grip on bumpy down hill sections of trail. I had the local shop bleed them, and they were great for another two months of riding. Then I noticed the same issue. Hit a bunch of bumps or chatter and the rear brake lever would lose most of the stopping power.

Once the rough section is past, the brake returns. After having the shop bleed the brake near the end of our fall riding season, the bike was stored for about 2 months, and just within the past 3 weeks we have been able to ride again. I can feel the issue returning.

My question. Is the shop doing a half assed job bleeding them? They work great for a few weeks/month. Is there a loose bolt/screw somewhere allowing air to leak into the system? Is there a seal somewhere that could leaking air into the system?

Thanks if anyone has any advise.
 

·
Never enough time to ride
Joined
·
1,575 Posts
My guess would be that there is a loose bolt some where or possibly a bad seal. I don't recall hardware torques off the top of my head buy I would check with SRAM/Avid and run through with a torque wrench.

There is always the possibility that the shop is taking a short cut and missing some air, if you have another shop locally take it to them and see if the results are different. If in doubt have them send the brake into QBP and have the boys over there do it, always had great results from them when I couldn't get a brake working in the shop.

I've got a couple sets of J7's one is an original gen and the second is a 3 year old set of Black ones, both have needed nothing more than a bleed once a year, the first set went the better part of 3 years with out a bleed, don't recommend that however.

happy trails...

squish
 

·
Registered
Joined
·
66 Posts
Discussion Starter · #3 ·
Will do. Seemed weird to me that it is always the rear going out. Leads me to believe it is a seal or loose bolt. I'm weighing the options of just getting the Juicy bleed kit instead of paying the shop $20 to bleed them again....

Anyone ever figure a way to make their own?
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top