Mountain Bike Reviews Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
278 Posts
Discussion Starter · #1 ·
just picked up my new 2006 GT i-drive 5.4. noticed that the fox float rear shock had a bit too much sag (was set at 170-180 psi...i'm 238lbs). pumped it up to 220psi....disconnected the pumped and noticed it still had sag. checked the pressure and it was back to 170 psi. now i know some air will fill the hose but 40-50 psi !!? also...when i just lean over the seat and pressed down on the seat/bike i could hear what sounded like bursts of air from the shock...this didn't come across to me as a good thing. is this normal??? taking it back to performanace bikes today for a check.
 

·
Registered
Joined
·
82 Posts
oil leak

well, i had my rear shock serviced 3 wks back and i noticed some oil build up around the rubber ring and thought it was just residue from the service. after five rides the oil is still there.i clled my lbs and they said it has to be sent back to ffox. after reading some of the threads i fear for my life,it sounds like total nightmare. i havent paid for the service yet, should i ask my lbs to wave the charges and just send it to pushed since they didnt fix the shock? i gave it to them with no oil leaks, anybody with the same expierience?
 

·
Registered
Joined
·
278 Posts
Discussion Starter · #3 ·
other FOX news

well...i've found a few more posts on fox rear shocks and 85% of them are negative...all were negative when discussing sending shocks back for repair...seems like "customer service" is unheard of with these guys. regarding my psi issue....from more posts i've discovered that each time you check the pressure on the rear shock you lose A LOT of pressure as it escapes thru the hose (other than a few shock that have valves preventing this....seems like a no brainer to have this on all). well...pumped my shock up a bit higher and seems to be OK....haven't gotten to hit the trails yet so i'll found out more after the weekend.
 

·
Do It Yourself
Joined
·
5,720 Posts
ocguy2004 said:
well...i've found a few more posts on fox rear shocks and 85% of them are negative...all were negative when discussing sending shocks back for repair...seems like "customer service" is unheard of with these guys. regarding my psi issue....from more posts i've discovered that each time you check the pressure on the rear shock you lose A LOT of pressure as it escapes thru the hose (other than a few shock that have valves preventing this....seems like a no brainer to have this on all). well...pumped my shock up a bit higher and seems to be OK....haven't gotten to hit the trails yet so i'll found out more after the weekend.
If you check your air pressure by sag, that should take the gauge pressurization out of the equation. If you have too much sag, add more air. If it doesn't hold you have a leak. Pump up the shock to 250 psi and dunk it underwater to check for bubble to help eliminate any troubles with the schrader valve. Otherwise, it's probably the seals. The seal kit is only a few dollars and it only takes a few minutes to install.

But overall, the Fox shocks work great. Fox sells A LOT of shocks. So it's no wonder there are some issues. These issues are relatively low percentages of the overall number of Fox shox out there. People don't post up on a regular basis, "Hey my Fox shock is working great!" so you don't hear from the silent majority. The other thing on the wait times is this is the busy summer season. I bet Fox turn around times are much faster in January.
 

·
Registered
Joined
·
278 Posts
Discussion Starter · #5 ·
thanks for the feedback

thanks for the advice....i agree most people log on to complain about stuff (guilty...) i pumped up the shock to about 250 last nite and it seems to be a more acceptable sag for me....i will try the water-test though to check to any leakage...thanks again!
 

·
Registered
Joined
·
1,645 Posts
ocguy2004 said:
well...i've found a few more posts on fox rear shocks and 85% of them are negative...all were negative when discussing sending shocks back for repair...seems like "customer service" is unheard of with these guys. regarding my psi issue....from more posts i've discovered that each time you check the pressure on the rear shock you lose A LOT of pressure as it escapes thru the hose (other than a few shock that have valves preventing this....seems like a no brainer to have this on all). well...pumped my shock up a bit higher and seems to be OK....haven't gotten to hit the trails yet so i'll found out more after the weekend.
yep, fox is awful and so are thier suspension...started looking to replace it now rather than when it tits up...which it will, count on it
 
G

·
Homebrew said:
But overall, the Fox shocks work great. Fox sells A LOT of shocks. So it's no wonder there are some issues. These issues are relatively low percentages of the overall number of Fox shox out there. People don't post up on a regular basis, "Hey my Fox shock is working great!" so you don't hear from the silent majority. The other thing on the wait times is this is the busy summer season. I bet Fox turn around times are much faster in January.
Exactly, the same is true with other suspension companies.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top