Mountain Bike Reviews Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter · #1 ·
Has anyone else out there had trouble with breaking chains on the new Dynasys 10 speed drivetrain? I snapped a chain in August (mind you it was a shift under too much torque) but last night I snapped a new chain twice while not shifting? I was torquing in a high gear on a climb and snapped the new chain (it had about 6 or more rides on it). I am by no means a monster, 5'11" and 150 lbs. Thanks for any input.

Btw, I've never snapped a chain on my old bikes.
 

·
Former Bike Wrench
Joined
·
15,976 Posts
KMC X10SL, no more breakage.
:yesnod:

KMC X10 chains are great...

Make sure whatever brand you use, DO NOT reuse pins. Once you push a pin out, that link is no good anymore. Only use quick links (KMC, Connex, and SRAM) or specific connection pin (Shimano...though you can use a quick link as well).
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #5 ·
Thanks for the info. My issue was that I didn't have any quick links and did reuse the pin and that is where (I think) it snapped the second time. But I'm still unsure of the first break, it broke under torque but I was not shifting. Anywho, I'll give the new SLX chain a try and if it breaks, I'll pick up a KMC. The tech at my LBS did inform me of not reusing a pin that was pushed out and to use quick links. We'll give that a go......
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top