Mountain Bike Reviews Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
120 Posts
Discussion Starter · #1 ·
Of course not, they blow.

I'm on my third high pressure shock pump now and every pump that I've had has lost major pressure while disconecting. I've tried every technique that I can think of to disconnect but nothing has worked so far. Is there any pump or technique that I'm missing?
 

·
Registered
Joined
·
258 Posts
Are you absolutely sure they are losing pressure?

With normal operation, there will be pressurized air in the line that leaks out upon disconnecting. You will hear this as air escaping. When you re-connect the shock pump back to the shock, air has to come out of the shock to equalize the pressure in the pump, dropping the pressure inside the shock by 2-10 psi, depending on the volume of the shock.

This pressure loss happens when the shock is re-connected, not disconnected after pumping.
 

·
No, that's not phonetic
Joined
·
14,313 Posts
There are a number of air "lossless" pumps out there. They have a plunger in the pump head that depresses the shrader valve core independently of threading the pump head onto the valve stem. You can control when the valve core gets opened via a telescoping threaded 2-part head. Before removing the pump from the shock, you back the plunger out of the valve core, and so when you then unscrew the pump, the only air that escapes comes out of the pump, not the shock (where the valve is already seated). My personal favorite is the Topeak DXG.

 

·
Vaginatarian
Joined
·
5,686 Posts
crash_chainpin said:
Of course not, they blow.

I'm on my third high pressure shock pump now and every pump that I've had has lost major pressure while disconecting. I've tried every technique that I can think of to disconnect but nothing has worked so far. Is there any pump or technique that I'm missing?
the pressure you hear on disconnecting is the air in the hose/ pump, not the shock and when you re attach the pump the pressure loss is from the shock air refilling the hose/ pump. try pumping up the shock and checking the sag while the pump is still attached, after the sag is correct, disconnect the pump and recheck the sag, it should still be where you left it. I had a friend who threw his bike and pump across the parking lot for the same reason:nono: but there was nothing wrong
 

·
Registered
Joined
·
120 Posts
Discussion Starter · #8 ·
dan0 said:
the pressure you hear on disconnecting is the air in the hose/ pump, not the shock...
No, it's not the hose pressure, I know the difference. For some reason the head of the pump is losing its seal on the valve body before it releases the valve stem. I can lose around 50 psi even if I spin it off as fast as humanly possible.
 

·
Vaginatarian
Joined
·
5,686 Posts
crash_chainpin said:
No, it's not the hose pressure, I know the difference. For some reason the head of the pump is losing its seal on the valve body before it releases the valve stem. I can lose around 50 psi even if I spin it off as fast as humanly possible.
you can replace the inner valve stem, they are the same as car tire valves, . maybe there is a little piece of junk stopping the valve from closing all the way. my friends fork was doing the same thing, went to pep boys and now all is well. costs about $1.50 + $3 for the valve stem tool
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top