Mountain Bike Reviews Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter #1
So I have creaks in two locations in my nrd frame. I took the bike into two shops. I explained and demonstrated at both shops how I could make the fron end creak by rocking the bars back and forth. And the creak on the rear end only occurs under hard peddling, even while standing.

The first shop is not a Giant dealer, but one of the better shops in the area. They took the bike apart and ended up telling me that one creak was in the headtube/downtube gusset and the other was in the shockmount/seatube gusset.

So I took the bike to the shop that I bought the bike from and told them about the creaking. They blamed the fork and the seatpost. The lubed the seatpost and sent me on my way. When I was riding back to the car the bike was still creaking as bad as ever.

So I went back in and talked to the head mechanic. He tried to explain to me that silt has worked its way into the bearings and was causing the creak. He told me that I could wash it out (even carefully with a carwash spray) and clean it out. He went on to tell me that at the end of the season I might want to take the frame apart and clean out the bearings.

He said all this even though it doesn't creak if the suspension is bouncing up and down like crazy. I pretty much felt like he was trying to blow me off. anyways, has anyone else had this problem? it is driving me nuts to the point that I hate riding it.
 

·
[paste title here]
Joined
·
515 Posts
I think i have the same problem, but only for the rear of the bike. But it creaks everytime I pedal. Ive been trying to locate every since it happend about a week ago. My guess was that it was the top bushings new the rear shock that was doing it. When I compress the shock I notice that when i lift the seat theres a lilttle thump, like there was a little play.. This happend often when I had the play in my shock but now its only when I compress the shock. (Anyone know what is causing this?) It also has the creaking noise I get everytime I lift the bike up. Im still trying to pinpoint where it is. Its also driving me nuts, but Im just trying to ignore it.

I did have the front end creak but that was only when I turned the bike. It turns out that the cable stops for the housing in the front was dusty and the combination of the metal ferrules caused it to creak slightly. Check to see of its the cable housing ferrules that might be causing it.

BTW, I just got the bushing kit from john and im going to see if the worn rear bushings had anything to do with that noise.
 

·
Registered
Joined
·
63 Posts
I had a similair creaking noise in the rear of my NRS2 and located it at the rear seatstay bushing. I took it aprt, cleaned and lubed it and have not had a creak yet. I also have that "thumping" noise and I know it is coming from the bottom rear shock mount. Apparently it is a self destructive thing and cannot harm your frame so untill I get a chance to ge to the LBS I am just gonna deal with it.


mtnbikerdude87 said:
I think i have the same problem, but only for the rear of the bike. But it creaks everytime I pedal. Ive been trying to locate every since it happend about a week ago. My guess was that it was the top bushings new the rear shock that was doing it. When I compress the shock I notice that when i lift the seat theres a lilttle thump, like there was a little play.. This happend often when I had the play in my shock but now its only when I compress the shock. (Anyone know what is causing this?) It also has the creaking noise I get everytime I lift the bike up. Im still trying to pinpoint where it is. Its also driving me nuts, but Im just trying to ignore it.

I did have the front end creak but that was only when I turned the bike. It turns out that the cable stops for the housing in the front was dusty and the combination of the metal ferrules caused it to creak slightly. Check to see of its the cable housing ferrules that might be causing it.

BTW, I just got the bushing kit from john and im going to see if the worn rear bushings had anything to do with that noise.
 
1 - 3 of 3 Posts
Top