Mountain Bike Reviews Forum banner
1 - 4 of 4 Posts

·
{Believeland}
Joined
·
277 Posts
Discussion Starter · #1 ·
So i just bought a used 2009 specialized p1 to ride at ray's this season. Before he sold it though, he had installed a deity vendetta crankset. While riding the bike though, i occasionally hear a very loud creak/pop noise, and when it occurs it almost seems as though it skips for a half second. I know that my chain tension is good, and i am pretty positive it is coming from the BB or crankset... Any help or ideas?
 

·
Registered
Joined
·
2,431 Posts
Is the chain old?

Could have some skipping type issues from a mismatch of new cranks/old chain.

I'd be pretty sure the cranks themselves aren't the issue if they're new as you have said.
 

·
{Believeland}
Joined
·
277 Posts
Discussion Starter · #3 ·
everything is almost brand new actually. the weird part is that the noise only happens ever so often (maybe 10 times within 6 hours of riding) and its usually at complete random too. I try cranking down hard to recreate the sound but nothing happens. It just seems to be at complete random:skep:
 

·
Registered
Joined
·
12,083 Posts
XCkiller said:
everything is almost brand new actually. the weird part is that the noise only happens ever so often (maybe 10 times within 6 hours of riding) and its usually at complete random too. I try cranking down hard to recreate the sound but nothing happens. It just seems to be at complete random:skep:
I had an old ISIS BB do that, turned out is was the BB bearings, jamming then releasing....
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top