Mountain Bike Reviews Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
I'm sort of new to biking and I think I have a problem with my bottom bracket. I have a Specialized P2, completely stock except for the rear rim. Whenever I go to pedal up a hill or really start to dig, I get a loud "CRUNK" or like a metallic type of popping sound. It occurs when the left crank is at approximately 8 O'clock to 10 O'clock. I posted in the drivetrain forum, but didn't get any replies to this. Could the bearings just be loose in the bb, or is there something with the boxguide thats on there or.....Just looking for help and a way to fix it.

Thanks,
Ian
 

·
Registered
Joined
·
9,444 Posts
jibber54520 said:
I'm sort of new to biking and I think I have a problem with my bottom bracket. I have a Specialized P2, completely stock except for the rear rim. Whenever I go to pedal up a hill or really start to dig, I get a loud "CRUNK" or like a metallic type of popping sound. It occurs when the left crank is at approximately 8 O'clock to 10 O'clock. I posted in the drivetrain forum, but didn't get any replies to this. Could the bearings just be loose in the bb, or is there something with the boxguide thats on there or.....Just looking for help and a way to fix it.

Thanks,
Ian
Dissassemble it all check & for any rough bearings in the BB, Pedals, or rollers.
 

·
Chilling out
Joined
·
6,036 Posts
If the sound happens reliably at one orientation of the crank then I'd favor a bottom-bracket issue.

Either some bearing is shot, or the bb is loose in the frame, or the bb is dirty/rusty in the frame.

1st diagnostic I'd avise is to check that neither crankarm is loose.

2nd diagnostic I'd avise is to pull the bb, clean the threads and the bb shell, turn the bb by-hand while it's pulled to see if you can feel any grinding, and possibly reinstall.

If you've got some easily identified grinding or "indexing" going on when turning the spindle by hand, then it's probably shot bearings inside. Replace unit.

If the thing spins smooth in your hands, go ahead and reinstall. make sure to lube the threads in the frame with some kind of grease, and torque up properly.

Luck.
 
G

·
dude, me too

I have the p.2, and the same thing going on with me. except mine is both sides. everytime i stand up and pedal, crack crack. its very anoyying and may be a prob.
It has do do with the bearings, i have figured that one out.
 
G

·
jibber54520 said:
did you find a solution to the problem? Or do i have to buy a new Bottom Bracket
Im not sure what im doing yet.... But i can still ride with it. Its just super anoyying.
if it breaks to a point where its not ridable. I think i am going to replace it.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top