Mountain Bike Reviews Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
Anyone have any problems with the Avid BB7 brakes as I have a set on my RIG and the constant wurring sound coming from the back break is doing my head in. I have tried altering the dials loads of times without any success. The noise seems to get loader the faster I am going (the front break is fine)

Any coments or advice?
 

·
Registered
Joined
·
122 Posts
Check the rear wheel alilgment and perhaps try some spacers to adjust brakesaddle height, sounds like the rotor might have a small connection to the brakesaddle or something..

My bb7's work just fine, of course the power is not as good as my Hfx comps but the break-in is just ongoing..
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #3 ·
Ive had another look at the rear wheel on closer inspection I think you may be right about wheel alignment. I think its probably about a fraction of a mm out on one side. It will take quite a bit of trial and error to get it right but should be able to fix it without taking it to the LBS.

Thank for the advice much appreciated.
 

·
Recovering Weight Weenie
Joined
·
8,821 Posts
LIMEY said:
Ive had another look at the rear wheel on closer inspection I think you may be right about wheel alignment. I think its probably about a fraction of a mm out on one side. It will take quite a bit of trial and error to get it right but should be able to fix it without taking it to the LBS.

Thank for the advice much appreciated.
Yeah, be glad you are running the Avid's in this situation too! With another brand..you might just have to live with it! :eek:
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top