Mountain Bike Reviews Forum banner
1 - 7 of 7 Posts

·
No, that's not phonetic
Joined
·
14,313 Posts
I tried a set for Avid and they didn't even survive the bedding in. The pad material cooked off the carrier when they got really hot. Something seriously wrong with that I'd say...
 

·
Registered
Joined
·
1,158 Posts
Discussion Starter · #3 ·
tscheezy said:
I tried a set for Avid and they didn't even survive the bedding in. The pad material cooked off the carrier when they got really hot. Something seriously wrong with that I'd say...
That experience surely sux, but my 2 sets used were comparable to Hayes and Avid originals in performance and durability... Anyone else have Aztec experiences?
 

·
Unshaven Yak
Joined
·
503 Posts
I installed a set on my XT 4-piston units (front 8" rotor) & I had a serious problem with glazing, they worked fine for a bit, then on a seriously steep section I could feel the pads hit the disc on cue, but no bite at all from the pads (dry conditions); I ran off trail & into the brush. Replaced with standard Shimano metallics & things back to normal (looked at the Aztecs & the glaze was very apparent on the outside edge of the pad). I may try them in the back where this may not be such an issue.

One thing though, I do have an issue with a pulse that raises its ugly head from my front 8" rotor....I don't have a clue what causes that. Time for a search unless someone can enlighten me. I don't think there are any bubbles in the system as power is good & the caliper is aligned properly.
 

·
Team Sanchez
Joined
·
4,369 Posts
I tried a pair of Aztecs for my Avids, and I couldn't get them to bed. After 50 or so hard stops, they still lacked any breaking force. Needless to say, they went in the recycle bin, and I got some Kool stops instead. The Koolstops work great.
 
G

·
Yeah, I tried replacing my Avid pads with Aztecs, they lasted all of about a week. The never seemed to bed in, were really weak on the stopping power and on the 4th ride of the week I felt a vibration coming from my rear brake. When I pulled the pads they had about 40% of the pad surface chunked away. Not even worth the $15 I paid for them.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top