Mountain Bike Reviews Forum banner
1 - 2 of 2 Posts

· Registered
Joined
·
571 Posts
Discussion Starter · #1 ·
Just looking for others experience. I have a 2021 SID SL Ultimate that came new on my 2022 Blur. Within the first few weeks of riding it the fork basically locked out. It started getting stiffer and stiffer over a few rides (I check the air pressure every ride and did notice any air loss more than the normal few psi from removing the pump, plus I was adjusting the pressure to tune the ride). I started another thread on it and was given some good advice ( 2021 RockShox SID SL Ultimate help ). I disassembled the fork and found the lower was definitely pressurized b/c I heard air escape when I removed the lower air spring bolt. I inspected all of the seals, shaft, piston, and cylinder but couldn't find a issue. I called the SRAM customer service to see if there was any updates to the parts or any known issues, they said there wasn't and they didn't seem really interested in helping me. I called the shop I purchased the bike from and they did not know of any issues. I had them check on get me a rebuild kit but they found that there was none available until next year. I checked with all the shops in my local area to see if they had seals but none did. So I put new foam rings in and new crush washers and assembled the fork with the old seals. It felt great the first several rides but during a 24 hour solo race the fork started getting stiff again, to the point my hands were killing me and I was having a hard time riding smooth.

I will be calling the shop I bought the bike from when they open next week. But I figured in the mean time I would see if any else is having this issue and if so what you may have found.
 

· Registered
Joined
·
93 Posts
I had the same thing happen to me with my 2021 Pike Ultimate yesterday when I dropped the lowers. I noticed I couldn't use the last inch or so of travel running low pressure but didn't think much of it. I wanted to change to a thicker oil and when I banged out the foot bolts I could hear a hiss. Then the lowers wouldn't drop without a solid tug. My airspring doesn't have too much grease on it so I'm not sure what's going on either. Rode last night and was using full travel with 10 more psi. I don't think that had anything to do with the fresh service because I had only ridden maybe 20 hours since the last time I dropped the lowers. Curious to hear the cause of this . . .
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top