Mountain Bike Reviews Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
631 Posts
Discussion Starter · #1 ·
I've got an '07 TALAS RLC and the lock out lever is binding. When I turn the lever, the compression adj. knob also turns. Any ideas? I hope so, this is startin' to pi$$ me off.


cheers,
simp
 

·
carpe mañana
Joined
·
7,308 Posts
simplton said:
I've got an '07 TALAS RLC and the lock out lever is binding. When I turn the lever, the compression adj. knob also turns. Any ideas? I hope so, this is startin' to pi$$ me off.

cheers,
simp
Have you wrecked at caused the bar to spin around and jam the damper controls into the downtube? I've done that before and I had similar behavior to what you describe.

_MK
 

·
Registered
Joined
·
204 Posts
simplton said:
I've got an '07 TALAS RLC and the lock out lever is binding. When I turn the lever, the compression adj. knob also turns. Any ideas? I hope so, this is startin' to pi$$ me off.

cheers,
simp
My '06 fork behaves the sdame way since new...compression knob spins with lockout (when you engage it) but does not spin back when you disengage it. I assumed it was a goofy "feature" and not a mechanical problem. The action ofthe lockout lever itself is very smooth though...so if you have a binding feel then there may be something else going on with your fork.
 

·
Registered
Joined
·
631 Posts
Discussion Starter · #4 ·
05stumpy said:
My '06 fork behaves the sdame way since new...compression knob spins with lockout (when you engage it) but does not spin back when you disengage it. I assumed it was a goofy "feature" and not a mechanical problem. The action ofthe lockout lever itself is very smooth though...so if you have a binding feel then there may be something else going on with your fork.
Yeah, that's exactly what mine was doing. I eneded up taking off the rebound dial, loosened up the three 1.5mm allen lock screws on the lockout lever, and lifted off the lever. I cleaned everything up and replaced the grease that was there from the factory with some very light silicon grease and reassembled. Things seem better now. I think the grease from the factory was causing some friction and the three locking allen screws may have been a bit tight.

In the end it appears that the compression adj. ring still wants to move with the lock out lever, but pretty much stays put. You can find the instructions I used here.

Hope that helps.

cheers,
simp
 

·
Registered
Joined
·
204 Posts
good info :thumbsup: , glad to see Fox has some proper servicing info available now...it was all a big mystery in '05!

I'll have a look in there and post if your suggestion helps.
 

·
Registered
Joined
·
631 Posts
Discussion Starter · #6 ·
05stumpy said:
good info :thumbsup: , glad to see Fox has some proper servicing info available now...it was all a big mystery in '05!

I'll have a look in there and post if your suggestion helps.
Cool man. Good luck. Like I said, it's still not perfect, but certainly better than it was...

cheers,
simp
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top