Mountain Bike Reviews Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
511 Posts
Discussion Starter · #1 ·
finally got back on teh saddle after 2 weeks of no time to ride.... 03 psylo had no compression control/climb-it control!! went through the entire oil change manual...all went well. next day (today) same problem, no climb it control, little resistance other than the spring, and it bottoms out half way down. i would assume a seal/o ring is the source of the problem, but the seals are only 4 months old with light riding since then... (long hours working) i gave a visual check to all the o rings yesterday, but i thought they looked good.... whats your take? i could use any advise you have... just to rule out some things, i did bleed it , and it did work properly last night.

if it is a seal kit that i need, is it one large kit or are there different kits available that i woul dhave to order separately if i do it my self? can i do it myself? LBS did it last time for a lot of $$...
 

·
Registered
Joined
·
938 Posts
Well, I doubt that the seals are that expensive; if there's just one blown, you could probably find a cheap replacement at a hardware store. Personally, I think that you messed up the bleed. Did you get covered in oil while you were doing it? Because if you didn't get at least one good shot in the eye, you did it wrong, my friend. :p Also, did you have the fork set at max travel while you were servicing it? That would probably screw it up. I would just take the pure damper out, inspect it for any obvious breaches, change the oil and be certain to add enough! Then bleed like crazy. Bleed til oil is pouring down the walls of your home. Then bleed some more. And make sure you top off the oil in the damper. Be careful adding the damping rod back in, and make sure you tighten it like they say in the directions.

Good luck!
 

·
Registered
Joined
·
6,843 Posts
Yeah, if you lock out the fork, and it compresses part way down before stopping, that's usually a sign there's air in the damper.

If you use a syringe and bleed it according to the instructions, you should be back in business.
 

·
Registered
Joined
·
511 Posts
Discussion Starter · #4 ·
I bled till i could bleed no more

i had a chance to work on it this afternoon... from start to finish and a couple shots to the ceiling by accident. same problem... i inspected all o rings which looked like they are in good shape. im no expert though.... there was no damage is what i should say...

initially the fork worked perfectly.... had it on the bike, test ride: lockout, rebound and travel control all worked flawlessly. a few hours later, NO climb it control, fork depressed with only resistance of spring and comes to an abrupt STOP about half way (as far as it will go) regardless of climbit control position. The entire stroke is reduced. rebound im unsure of, got a little angry and walked away after that. NO PUDDLE where the bike was sitting.

What travel setting should i use? it was fully extended first time round.... this time all the way down.
am i kicking a dead horse? ive had some problems in the past with this fork, but usually its been minimal and fixed by the lbs. ive just about had it and Im ready to trade it in since ive invested way too much already in repairs. last few problems ive blamed on the LBS (just one in town) i think im ready point my finger at the fork though...

feel free to ask for clarifications.... i know im all over the board on this one

thanks
 

·
Registered
Joined
·
938 Posts
Bummer, man. Air getting into the Pure damper is a common problem. I read somewhere once that it would happen when the blow-off valve (Homer valve) opened up, like if you had the fork locked out and hit a big bump. That was sort of my feeling. Even if I just had the compression damping set around half-way in, I think that that was a bad thing. I think that it's best to ride the fork with the compression all the way open.

Have you checked out angryasian's website? He's an expert on rock shox forks, and as I recall he had a mod for the pure damper that would solve a lot of its inherent problems. You might try posting on his message board, and see if you can find his mod. It had to do with removing the spring on the floating piston, I believer. I never tried it myself.

Good luck!
 

·
Registered
Joined
·
938 Posts
Ok, this is straight from Angry:

"Here are the instructions again for the Pure mod. It's actually quite simple, and in spite of what some certain industry guys have said, everyone seems to agree that it does the job quite nicely. When you're done, your lockout should be less finicky, and more importantly, your fork's spring rate will be slightly more linear. Here goes:

Essentially, you need to unscrew the top cap from the compression damper, then remove everything from the floating piston up (just unscrew the cap from the shaft and slide everything off the top). The floating piston (it's the white thing at the bottom of the spring with the o-ring around it) needs to get reinstalled on to the compression rod so as to provide a seal for the damper chamber (I spaced the seal down the shaft a bit by installing a bottom-out bumper on top of it). After installing the floating piston and bottom-out bumper, you just need to reinstall the top cap and you have the complete assembly. At that point, you just need to put the damper back together: fill the damper to about 110mm (measured from the top of the stanchion with the rebound damper fully extended; make sure to periodically cycle the rebound damper while filling to purge any trapped air for an accurate measurement) and you should be good to go."
 

·
Registered
Joined
·
938 Posts
One last question: when you're doing the bleed, did you leave the rebound wide open, and make sure to get the air out of the rebound chamber? If there's still air in there, you might run into the problems you've been having.
 

·
Registered
Joined
·
6,843 Posts
Fat Elvis said:
Ok, this is straight from Angry:

"Here are the instructions again for the Pure mod. It's actually quite simple, and in spite of what some certain industry guys have said, everyone seems to agree that it does the job quite nicely. When you're done, your lockout should be less finicky, and more importantly, your fork's spring rate will be slightly more linear. Here goes:

Essentially, you need to unscrew the top cap from the compression damper, then remove everything from the floating piston up (just unscrew the cap from the shaft and slide everything off the top). The floating piston (it's the white thing at the bottom of the spring with the o-ring around it) needs to get reinstalled on to the compression rod so as to provide a seal for the damper chamber (I spaced the seal down the shaft a bit by installing a bottom-out bumper on top of it). After installing the floating piston and bottom-out bumper, you just need to reinstall the top cap and you have the complete assembly. At that point, you just need to put the damper back together: fill the damper to about 110mm (measured from the top of the stanchion with the rebound damper fully extended; make sure to periodically cycle the rebound damper while filling to purge any trapped air for an accurate measurement) and you should be good to go."
I did this mod and was not happy. The fork lost its ramp-up, and had a lot of brake dive on downhills on my XC/trailbike. It was very good at eating big bumps at speed (I actually was using full travel!), but it was so sketchy downhill that I put the floating piston back in. Maybe that mod works best for SID forks.

I now have the fork on my FRHT and the progressive feel (with the stock PURE setup) works pretty well for that kind of riding.
 

·
Registered
Joined
·
54 Posts
mine did this too

SuspectDevice said:
The one thing it seems you havent checked is the base of the pure tube. Are you loosing oil through the bottom of the tube and into the lowers of the fork? That has happened with a few Psylos I've worked on.
Same thing happened to me. I found the lower O ring of the pure tube contaminated with some kind of debris following overhaul at Hippie Tech. Cleaned and reinstalled to fix the problem. You can easily check this O ring by removing the bolt from the lower leg on the R/H side. If A LOT of oil pours out of it you have a bad/contaminated pure tube O ring, which is allowing the pure system oil to migrate down into the lowers. The O ring is under the white cap and the pure tube must be removed to access it.
 

·
Registered
Joined
·
511 Posts
Discussion Starter · #12 ·
elvis: the rebound was open

suspect & dustoff: when i put everything back together on the right leg, it did have a slow drip when i put the pure tube back together. would a new o ring fix the problem? i havent taken it apart again to day yet, out of oil. would you reccomend a trip to trilling and try to find a similar o ring? am i better off spending some $$ with a kit from the LBS.
 

·
Registered
Joined
·
511 Posts
Discussion Starter · #14 ·
3rd time

changed the oil again with no luck... tomorrow im going to place an order with the LBS for a seal kit. is there any way to isolate the problem? what are some symptoms of bad seals? ive only seen it get oil on the floor... not so in this case. how do i know where oil is leaking from the pure tube to the lowers? when i pulled the bolt from the bottom to release the lowers there was a large amount of oil.. and hardly any in the pure tube. I would assume the o ring in the plastic seal head, but how can i be sure?
 

·
Registered
Joined
·
938 Posts
Good deal, man! Sounds like you've found the source of the problem. I wish I could offer some advice, but it's been a year since I tore mine apart, and I don't really remember all of the seals in the damper. Well, I'll be stripping it down soon to put in new enduro seals, so I'll have my fingers crossed that there aren't any internal problems. You can probably order a seal kit from RS for not too much. I hope things work out for you.
 

·
Registered
Joined
·
54 Posts
You found it

Fat Elvis is right, you have found the problem. You may be able to find a sutible replacement O ring at an auto parts store or hardware store. LBS may have a single O ring available vs. buying a whole kit as well. Another option is to buy the kit online at http://www.bikeparts.com/search_results.asp?ID=BPC322860. This would have the O ring you need now and parts for future use should the need arise. I would inspect the O ring and seal area first and make sure your problem isn't just as simple as contamination (like mine was). I cleaned the oring and reinstalled with no problems (thus far anyway :).
 

·
Registered
Joined
·
511 Posts
Discussion Starter · #17 ·
thanks for all the help, ill post results when the kit comes in
 

·
Registered
Joined
·
511 Posts
Discussion Starter · #19 ·
i actually got pretty lucky on this one. i called a couple friends from college and got hooked up with a free seal kit last second. Everything is is working like new again except for the damn rubber knobs that spin if im not carefull w/ them.
 
1 - 19 of 19 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top